
Quick user guide

GET STARTED

Installing the SIM card, memory card and 
battery

ATTENTION : 
•    Risk of swallowing small objects! The SIM card & memory 
card can be removed. Small children can swallow them.
•    Do not bend or scratch the SIM card. Prevent any contact 
with water, dirt or electrical charges.
•   Turn off the phone and disconnect the charger before 
removing the battery cover.

Remove the battery cover

INTRODUCTION 
D28 is an extraordinary 2G clam shell phone with dual display 
( E-paper Always-On external display, user can no longer miss 
the key information )

D28 is a CARE PHONE with features :
• M4/T4 HAC level
• Loud speaker
• 2M pixel camera
• Built-in large memory
• Talking dialing digits

D28

• Easy charging base
• Talking caller ID name
• Photo speed dial
• SOS button
• SwissVoice Care features

KEYS DESCRIPTION
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1 - Earpiece
2 - Main display
3 - Left selection key
4 - Navigation key
5 - Answer/Call key
6 - Photo memory Key

7 - Camera Key
8 - Dialing keypad
9 - Microphone
10 - Right selection key
11 - End / Power key
12 - Torch key

13
14

15

DISPLAY ICONS

External E-Ink Display	

Color Display	

Missed call

Battery FULLBattery LOW

Charging

Alarm ON New message

Earpiece 
amplification ON

Red – Ring; Green – 
Ring & Vibrate

Battery power 

Vibrate then Ring Bluetooth ON

Vibrate only Roaming

Silence

Signal strength

Headset Plugged in

Note! All the diagrams are for illustrative purposes. It may be 
slightly different from the actual unit.
In keeping with our environmental preservation and 
compliance commitment, we include Quick Start Guide in 
our packaging.  For digital copy of user manual and useful 
information, please visit our website or contact our Helpline.
www.swissvoice.net

Charge the phone

 -    Connect the USB plug of the adaptor to the charging 
socket (A) or place the device in the cradle (B).

ATTENTION:
•  Only use battery, charger and accessories that have been 
approved for using with this particular model. Connecting 
other accessories may be dangerous and may invalidate the 
warranty.
•  When charging the battery for the first time, it should be 
charged for at least 4 hours.

1st USE SETUP

-     Long press  to power up the phone

-      to select the desired language > OK
-     Input HH:MM > > DD/MM/YYYY > > 12Hr/24Hr >
> Save
( Press Menu >  > Settings > Phone > ..... User can 
modify the detailed settings )

BASIC OPERATION

Turn the Phone ON/OFF
-     Long press 

Make a Call
-     Enter the number 0…..9 ( Press Clear to delete )

-     Press  to dial ( Press H-Free for Handsfree. Press H-Held 

for Handset )

-     Press  to end the call
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Insert the SIM card (required) and the memory 
card (optional)

Call from phonebook

-     Press  >  to select the 10 photo memory; 
      or
      Press Names >  to select the number 

-     Press  to dial 

-     Press  to end the call

Receive a Call
-     Flip up the phone or press  to answer
-     Press  to end the call

-    Place the SIM card in the SIM card holder with the golden 
contacts facing down. Close the SIM card metal cover and lock 
it.
-    To expand the internal storage memory, you can insert 
a microSD memory card ( maximum capacity of 32 GB / not 
included). Insert the memory card into the slot until it stops as 
illustrated.

Insert the battery and replace the battery 
cover

-    Insert the battery into battery compartment with golden 
contacts of the battery facing downwards to the right of the 
phone. Press lightly on the top end of the battery until it 
snaps into place.
-    Replace and secure the battery cover until it clicks into 
place.

Adjust the earpiece Tone frequency
-      Press Menu >  > Settings > Tone Control….
         1. Normal frequency
         2. Low frequency
         3. High frequency

Adjust the earpiece loudness

-      During a call, press  to adjust the loudness
-      According to your need, it can reach the M4/T4 level

ATTENTION :
Excessive exposure to loud sounds may cause hearing damage. 

**  is the hot key for switching the keypad input 
between ABC, Abc, abc & 123.

**  is the hot key for entering special symbol.

Settings ( Ring tone & Volume )
-      Press Menu >  > Settings >….
-      Under the Settings menu, the following options can also 
be accessed
         1. Profiles
         2. Phone ( Setting Date/Time, Languages,.... )
         3. Charger LED ( Activate / Deactivate )
         4. Tone Control
         5. Call settings
         6. Security
         7. Restore
( Press Menu >  > Settings > Profiles > General > 
Customize..... User can select the Ring tone, Volume and 
others )

13 - Camera lens
14 - Torch LED Flashlight
15 - Front display
16 - Loudspeaker
17 - SOS key

18 - Charging contacts
19 - Headset jack
20 - Micro-USB socket
21 - Volume control 
(Hearing, Ringer and Audio 
Boost )

CALL Log
-     Press Menu >  > Call Log >…..
         1. Missed
         2. Dialled
         3. Received
-     Press  to select the desired number

-     Press  to dial out

ADD Phonebook contact
-     Press Menu >  > Phonebook >  > Normal > 

 > Add      
        1. Name > input the name
        2. Number > 0….9 
        3. Caller ringtone > select ring tone
        4. Options > Save 
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Messages ( SMS/MMS )
-     Press Menu >  > Messages > Write >  to select 
SMS or MMS
-     Input the text messages or attachment for MMS

**  is the hot key for switching the keypad input 
between ABC, Abc, abc & 123.

**  is the hot key for entering special symbol.

-     Press Options > Send to >  > Enter number or select 
from phonebook > enter the recipient phone number > OK > 
Options > Send
-     Under the Messages menu, the following options can also 
be accessed
        1. Inbox
        2. Drafts
        3. Outbox
        4. Sent
        5. Setting

Take a Photo
-     Press  > press again  to take a photo…..

( Press Menu >  > Multimedia > Gallery…. User can 
review the photos )

Multimedia
-     Press Menu >  > Multimedia >…..
        1. Camera
        2. Gallery
        3. Play Audio
        4. Recorder
        5. FM Radio

UNIQUE FEATURES HIGHTLIGHT

SOS Assistance button

-     Long press  for 3 seconds to dial out assistance 
number.
-     The recipient of the assistance call can press 0 to accept 
the call. D28 will enter handsfree mode automatically.
-     If the call was not accepted, D28 will keep dialing out 
until the call is accepted.

-     To terminate, press and hold  .

ATTENTION :
•  Remember to set the SOS numbers and inform all the 
recipients. 
•  To have SOS function working normally, the network 
service must be active.

Setting options :
( Press Menu >  > SOS Settings > ….. )
1.  SOS mode > Service center OR  5 Emergency numbers OR 
OFF
2.  SOS number > enter maximum 5 emergency numbers
3.  Service center > enter service center number 
4.  Voice message > Default voice help message OR User 
recorded message

Talking Dialing Digits
-     While pressing the numeric buttons, D28 will announce 
the corresponding number. 
( Press Menu > Settings > Profiles > General > Customize > 
Keypad….. User can select Talking dialing digits, Silence or 
Key tone. )

Talking Caller ID Name
-     User can record a name/message associated to the PHOTO 
phonebook contacts. When the incoming caller number 
matches the phone number in the photo phonebook , the 
corresponding recorded name/message will be announced 
instead of the normal ring melody.

( Press  >  > View > Edit > Caller ringtone >….. 
User can delete the recorded message to restore the normal 
ringtone)

PHOTO Phonebook
-     Press  >  to select the 10 photo memories

( maximum )

-     Press  to dial out

ADD PHOTO Phonebook Contact
-     Press  >  > Add…. ( Or, View > Edit..... for current 

contacts )

        1. Picture >  > Save 
        2. Contact > input the name and number > Save
        3. Caller ringtone > Record > record the name/    	                 	
            message 

TORCH
-     Press  to turn ON/OFF

SMART TOOLS 

Intelligent Ringer 
-     In order not to miss a call, the ringer loudness will 
automatically set to maximum when the same phone number 
calls the second time within 3 minutes after the initial missed 
call.

-     After the call is answered, the ringer loudness will be 
resumed to the user selected volume level.

( Press Menu >  > i.Ringer….. User can switch this feature 
ON/OFF )

Smart Notification
-     SMS will be sent to the Helper ( Mobile phone number ) 
for MISSED CALL or BATTERY LOW of your phone.
-     Helper mobile phone number can be set under the same 
Smart Tools menu.

( Press Menu >  > s.Notices….. )

Smart Care
-     SMS will be sent to the Helper ( Mobile phone number ) 
for LACK of PHONE CALL ACTIVITIES or LACK of PHYSICAL 
ACTIVITIES ( key detect, open/close of the phone, charging 
detection ).
-     Helper mobile phone number can be set under the same 
Smart Tools menu.

( Press Menu >  > Smart Care….. )

Helper
-     Remember to set Helper mobile phone number for SMS 
alert notification .

( Press Menu >  > Helper….. )
Remark : Sending SMS may require additional cost!

TECHNICAL DATA
Quad-band - 850 / 900 / 1 800 / 1900 MHz
Additional function - Bluetooth
Battery - Li-Ion, 3.7 V, 800 mAh
Earpiece volume - Maximal +35 dB
Talk time - up to 5 hours
Standby time - up to 7 days
Dimensions       - approx. 107 x 56 x 20 mm (closed)
                            approx. 200 x 56 x 12 mm (open)
USB connection - Micro USB
Headset connection - 3.5 mm jack, 4-conductor
                                    (TRRS) phone connector
SAR values - GSM 900 Head: 0.13 / Body: 0.56
                     DCS 1 800 Head: 0.15 / Body: 0.96

PROBLEMS AND SOLUTIONS

Problems Solutions

The mobile phone cannot be 
switched on

No battery inserted;
Battery is not charged.

The phone is requesting a PUK 
when I switch on the phone

If you do not have the PUK for 
your SIM card, please contact 
your service provider.

No signal quality is displayed No network connection. The 
mobile phone is in a location 
where there is no network 
service, please move to a 
different location or contact 
your service provider

A message appears in the 
display for some functions, 
indicating execution/use is not 
possible

Some functions can only be used 
after the respective service has 
been applied for. Contact your 
service provider.

Screen frozen or no response 
when pressing keys

Remove the battery for 3 
minutes and try again

No connection to the mobile 
telecommunication network

Contact your service provider

The “Insert SIM“ message 
appears in the display

Ensure that the SIM card has 
been installed correctly. Contact 
your service provider.

The battery cannot be charged 
or is empty within a short time

Battery is defective;
Place the phone correctly in the 
charging unit or connect the 
charging unit properly;
Clean the charging contact  of 
the mobile phone and charging 
unit with a dry soft cloth;
Charge the mobile phone for 4 
hours.

The mobile phone has 
accidentally got wet

Switch off the phone 
immediately, remove the battery 
and allow the unit to dry 
completely before powering it 
on again. 

• The ringing tone is issued via the loudspeaker. Take an incoming call first and 
then hold the phone to your ear. This prevents any possible hearing damage.
• Use approved handsfree equipment and appropriate holder while driving. It is 
essential to observe the applicable national laws and regulations.
• Always maintain a distance of at least 15 cm to implanted heart pacemakers 
to prevent interference. Do not carry the phone in a chest pocket when 
switched on. Always hold the phone to the ear furthest away from the 
pacemaker during calls. Switch the phone off immediately if you notice or 
suspect any adverse effects. Consult your doctor if you have any question.
• This phone is hearing aid compatible. If you wear a hearing aid, please 
contact your doctor or the hearing aid manufacturer to inquire about any 
possible impairments through mobile communication equipment.
• Do not rely on the mobile phone as a safeguard for emergencies. For a variety 
of technical reasons, it is not possible to guarantee a reliable connection under 
all circumstances.
• Ensure access to the power adapter plug is not obstructed by furniture or 
such.

ENVIRONMENT

system for which producers are responsible
Help us protect the environment in which we live!

DECLARATION OF CONFORMITY
The logo printed on the products indicates the conformity with all essential 
requirements ( RED directive : 2014/53/EU ). You can download the Declaration 
of Conformity from our website - www.swissvoice.net

WARRANTY
Please read carefully the user guide included in this box. D28 is an approved 
equipment in accordance with the European regulations, attested by the CE 
marking. The product you just bought is a technological product, it must be 
handled with care.
Note: You have a legal warranty on this product in accordance with the 
regulations applicable to the sale of consumer goods in the country in which 
you made this purchase.
For any information regarding this legal warranty, please contact your dealer. 
Without prejudice to the legal guarantee of the products, ATLINKS guarantees 
that the product in this box conforms to its technical specifications contained 
in the user guide included in the this box, and this during a warranty period, 
counted from the date of purchase of the new product, the date on your 
invoice or ticket checkout where is indicated the name of your reseller, and 
equal to: Twenty four (24) months for the telephone, excluding consumables, 
accessories and batteries. For any claim under this warranty during the warranty 
period, you must return the entire Product to your dealer, together with the 
proof of purchase, the invoice or receipt issued by your dealer, indicating 
the place of purchase and the serial number of the Product, following the 
appearance or discovery of the defect. ATLINKS undertakes to repair any 
defective item due to a defect in design, material or workmanship, at its 
expense, or to replace, at its expense, by an identical or at least equivalent 
element in terms of functionalities and performance. If the repair or 
replacement is impossible under normal commercial conditions, the Product 
will be refunded or replaced by a Product equivalent. Within the maximum 
limit allowed by the applicable law, the product or element replacement, which 
may be new or reconditioned, is warranted during a period of ninety (90) days 
from the date of repair or until the end date of the initial warranty period, 
whichever is the earlier greater than ninety (90) days, it being specified that any 
period of immobilization of the Product of at least seven (7) days will be added 
to the warranty period remaining to run. This warranty does not apply in the 
following cases:
- Installation or use not in accordance with the instructions in the guide of the 
user,
- Incorrect connection or abnormal use of the Product, especially with non-
compatible accessories, as indicated in the user guide,
- Product opened, modified or replaced by means of non-approved parts, serial 
number deleted, illegible, damaged,
- Normal wear, including normal wear and tear on accessories, batteries and 
displays,
- Failure to comply with the technical and safety standards in force in the area 
geographical use,
- Product having suffered a shock or a fall,
- Product damaged by lightning, electrical surge, heat source or radiation, 
water damage, exposure to conditions of temperature, humidity or other 
excessive ambient conditions or any other cause external to the product,
- Negligence or faulty maintenance,
- An intervention, a modification or a repair carried out by a not authorized by 
ATLINKS. 
If the returned Product is not covered by the warranty, you will receive a quote 
from repair that will mention the cost of analysis and transportation costs that 
you will be charged if you want the Product returned to you. This guarantee 
is valid in the country in which you regularly purchased the Product, provided 
that the country is a member of the European Union. Subject to the legal 
provisions in force, all warranties other than described herein are expressly 
excluded.
TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW,
A) THIS WARRANTY IS EXCLUSIVE TO ALL OTHER WARRANTIES EXPRESS 
OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, WARRANTIES OF 
MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE PARTICULAR;
B) ATLINKS DISCLAIMS LIABILITY FOR LOSS OR DETERIORATION OF DATA, 
LOSS OF USE LOST TO WIN, LOSS OF CHANCE, DEREVENUES OR INCOME, LOSS 
OF OPERATION, DAMAGES INDIRECT, CONSEQUENTIAL, CONSEQUENTIAL OR 
INCIDENTAL;
(C) ATLINKS LIABILITY IS LIMITED TO THE VALUE OF PURCHASE OF PRODUCT 
EXCEPT HEAVIL OR UNINTENTIONAL FAULT AND EXCEPT DAMAGE BODY

Atlinks Europe
147 Ave Paul Doumer 

92500 Rueil-Malmaison
France

Model : Swissvoice D28
A/W No. : 10001983 Rev.0 (EN)

Printed in China

This symbol means that your inoperative electronic appliance must 
be collected separately and not mixed with the household waste. The 
European Union has implemented a specific collection and recycling

TIPS ON THE BATTERY
• Only use batteries, cables and charging unit approved by the manufacturer, 
otherwise the battery could be damaged.
• Do not short circuit the battery. Always leave the battery in the phone to 
avoid accidentally short circuiting the battery contacts.
• Keep the battery contacts clean and free of dirt.
• The battery can be charged/discharged hundreds of times but its service life is 
limited. Replace the battery when the battery power has decreased noticeably.

NETWORK SERVICES AND COSTS
D28 is designed for use when connected to a mobile phone network. Using 
network services and SMS may result in traffic costs.

AREA OF USE
• Do not use the phone in prohibited areas.
• Switch the phone off without affecting nearby medical equipment (e.g. in 
hospitals).
• Do not use the phone in petrol stations or near fuels and chemicals.

SAFETY
• Prevent exposure to smoke, dust, vibration, chemicals, moisture, heat and 
direct sunlight. 
• The phone is not waterproof, please keep it dry.
• Only use original accessories and battery. Never attempt to connect other
products.
• Never attempt to connect incompatible products.
• Repairs to this device must be completed by qualified service personnel.
• Keep the phone and accessories out of the reach of children.
• The SIM card can be removed. Caution! Small children can swallow them. 


